Neue PDFs zeigen kein Thumbnail mehr an

Dieser Thread ist Teil einer Diskussion zu einem Artikel:  Zum News-Artikel gehen

irriducibile

Aktives Mitglied
Tach

Seit ein paar Tagen zeigen neu heruntergeladene/kopierte/usw PDFs zeigen keine Thumbnail-Vorschau mehr an. Das Komische daran ist, dass es bei älteren PDFs aber weiterhin geht. Irgendwie gibt es quasi ein Trenndatum von vor paar Tagen - bei den älteren wird eine Vorschau gezeigt, bei den neueren nicht. Aber keine Ahnung was da passierte, vermutlich ein Update.

Folgendes hat NICHT geholfen:
- Miniaturvorschau in den Einstellungen vom Adobe Reader einschalten
- Den Fixes for 64-bit Adobe Reader preview handler and thumbnails zu benutzen

Weiss jemand, was man sonst nocht tun könnte?

Vielen Dank
 

Billmar

Stammgast
Hallo irriducibile
Seit ein paar Tagen zeigen neu heruntergeladene/kopierte/usw PDFs zeigen keine Thumbnail-Vorschau mehr an. Das Komische daran ist, dass es bei älteren PDFs aber weiterhin geht.
Gemäss deiner Beschreibung könnte es an korrupten Thumbnail-Dateien im Ordner der "Temporären Dateien" liegen. Ich würde als erstes das Systemlaufwerk diesbezüglich bereinigen.

Das Bereinigen kannst Du im Explorer mit der rechten Maustaste auf dem Laufwerk und der Auswahl von "Eigenschaften" starten. Dann kontrollieren ob die Auswahl "Temporäre Dateien" markiert ist und dann mit "OK" starten.
DriveCleanUp.png
Dann Maschine neu starten und kontrollieren ob die Thumbs wieder angezeigt werden.

Gruss Mario
 

irriducibile

Aktives Mitglied
Danke, Mario. Werde es morgen versuchen.

In der Zwischenzeit gab es eine neue Entwicklung. Ich lasse die hier mal stehen, für den Fall, dass es weiterhilft.
Die Thumbnails erscheinen bei PDFs, die im Papierkorb liegen - nicht aber bei jenen aufm Desktop. Und wenn ich ein PDF vom Desktop in den Papierkorb und wieder zurück ziehe, dann erscheint das Thumbnail auch. Der Papierkorb dient also quasi als Thumbnail-Generator.
Das alles ist so seltsam...
 

irriducibile

Aktives Mitglied
Den Thumbnail-Cache hatte ich schon mehrfach gelöscht. Das hatte leider nichts gebracht, ausser dass gleich alle Thumbnails weg waren.

Inzwischen hat es wieder eine neue-neue Entwicklung gegeben. Durch den "Papierkorb-Trick" erscheinen nun Thumbnails, aber immer in so nem hässlichen weissen Rahmen/Quadrat eingebettet:

white borders.jpg

Wie kriege ich nun das wieder weg?
Ich hatte das Problem schon vor 1 Jahr, als ich den Laptop neu gekauft hatte. Wie ich es beheben konnte, weiss ich nicht mehr... ich glaube durch den Tipp hier, das mit dem Alpha Channel. Hat nun aber nix mehr gebracht.

Bin langsam mit dem Latein am Ende...
 

Jürgen N.

Stammgast
Bitte nicht lachen...
benutze PDF und Adobe Reader seit es das gibt. Also lange.
Habe noch nie ein "PDF-Thumbnail" gesehen.
???
Dank und Gruss Jürgen
 

Billmar

Stammgast
Hallo irriducibile

Scheint, dass die Acrobat Reader Installation wohl etwas angeschlagen ist...

Ich würde folgendes unternehmen:
  • Lade den Geek-Uninstaller von hier herunter: https://geekuninstaller.com/geek.zip und entpacke die ZIP-Datei. Das Uninstall-Tool benötigt keine Installation und ist sehr zuverlässig im Entfernen von Installationen (was nicht von allen Standarddeinstallationsroutinen gesagt werden kann ;-))
  • Starte Geek und suche die Acrobat-Reader Software. Deinstalliere den Reader und lass alle Registry-Einträge ebenfalls entfernen
Fahre jetzt die Maschine komplett herunter (kein Restart) und schalte die Maschine dann wieder ein.

Lade jetzt den Acrobat Reader neu von hier auf deine Maschine herunter:
Wähle dann im Menu links
Schritt 1: Windows 10
Schritt 2: German (oder die gewünschte Sprache)
Schritt 3: Reader DC xxxx.xxx.xxxxx German Windows (64b...
Klicke dann oben rechts auf Acrobat Reader herunterladen
Starte dann nach dem Download die AcroRdrDC2100720099_de_DE.exe (de_DE falls German gewählt ansonsten die Endung gemäss Auswahl) für die Installation.

Richte nach der Installation den Reader nach deinem Gusto ein - führe nochmals einen Neustart durch und konfiguriere erst jetzt in den Einstellungen "PDF-Miniaturvorschau im Windows Explorer aktivieren"

Hoffe, dass es damit klappt 🤞
Gruss Mario

@Jürgen N. : Sieht im Explorer dann etwa so aus
AcrobatThumbs.png
 

irriducibile

Aktives Mitglied
Danke, Mario. Hat leider nix gebracht. Also ja, teilweise. Thumbnails werden nun gezeigt, aber immer in diesem hässlichen weissen Quadrat. Dagegen hat aber kein Mittel geholfen. Ich glaube zwar, dass ein Update Schuld sein könnte, aber der Wiederherstellungspunkt ist inzwischen verschwunden.
 

Billmar

Stammgast
Hallo Jürgen N.

Wenn Du im Acrobat Reader DC unter Einstellungen -> Allgemein die Option "PDF-Miniaturvorschau im Windows Explorer aktivieren" anhakst kannst Du, nachdem der Zusatz des Acrobat Readers DC automatisch nachinstalliert wurde, im Windows Explorer bei der Miniaturansicht einen Thumbnail wie bei Word & Co. sehen.
AcrobatThumbs.png
Bei der "normalen" Ansicht wie in deinem Bild in #8 wird natürlich nur das kleine PDF-Icon angezeigt - etwas anderes würde auch keinen Sinn machen.
Ich persönlich habe die Thumbs standardmässig auch nicht aktiviert ;-). Beim Deaktivieren wird die Zusatzfunktion wieder deinstalliert.

Gruss Mario
 

Billmar

Stammgast
Hallo irriducibile

Habe mir die Sache nochmals angesehen und konnte halbwegs das Problem reproduzieren. Allerdings nicht mit dem "hässlichen Quadrat" aber mit einem komplett schwarzen Icon. Dieses reagierte so wie Du es in #3 beschrieben hast.
Und wenn ich ein PDF vom Desktop in den Papierkorb und wieder zurück ziehe, dann erscheint das Thumbnail auch.
Der Desktopausschnitt sieht bei mir dann so aus, wobei das Icon links im Papierkorb war und das Icon rechts noch nicht (oberes Bild).
Nach dem Löschen der Datei "IconCache.db" unter C:\Users\(User Name)\AppData\Local, dem anschliessenden Leeren des Papierkorbes und nach einem Neustart wurden die Icons wieder korrekt dargestellt (unteres Bild).
AcroIconCache.png
Bei den ganzen Aktionen ist mir aufgefallen, dass es immer nur die Icons auf dem Desktop betraf und nie die Icons im Explorer.
Das hat mich veranlasst das Ganze noch mit dem Ändern der Desktop Icon-Grösse zu versuchen. Das Ergebnis dabei war, dass auch dann die Icons wieder korrekt angezeigt werden (in allen drei Grössenstufen. Vielleicht wäre das von Anfang an DIE Lösung gewesen.

Gruss Mario
 

irriducibile

Aktives Mitglied
Danke, Mario. Mit "Ändern der Desktop Icon-Grösse" meinst du Gross - Mittelgross - Klein? Das hab ich versucht, hat aber nix bewirkt. Oder hast du was anderes gemeint?

IconCache.db hatte ich schon mal gelöscht, weil ich googlend diesen Vorschlag gefunden hatte, es half damals aber nicht. Vielleicht versuche ich es nochmals.
 

Billmar

Stammgast
Hallo irriducibile
Mit "Ändern der Desktop Icon-Grösse" meinst du Gross - Mittelgross - Klein?
Ja, genau das habe ich gemeint. Meine "schwarzen Icons" hat diese Aktion auf die "normalen" Adobe Icons zurückgesetzt - hat mich deshalb auf die Idee gebracht, dass das auch die Lösung für "hässlichen Quadrate" sein könnte. Die IconCache.db löschen ist aber sicher eine Möglichkeit die fehlerhaften Icons los zu werden.

Gruss Mario
 

irriducibile

Aktives Mitglied
Danke für die Hilfe. Leider hat nix was gebracht.

- Icon Grösse ändern
- Thumbnail Cache leeren
- IconCache.db löschen
- Diesen Fix benutzen
- Im Reader unter Einstellungen "Miniaturansicht" aus- und wieder einschalten
Zwischen den Schritten natürlich jeweils den PC neugestartet

Das Gute: Thumbnails werden überall wieder normal gezeigt, auch Desktop
Das nicht so Gute: Das weisse Quadrat bleibt, egal was ich versuche
 

Billmar

Stammgast
Hallo irriducibile
Letzte Idee :-).

Setze mal für das Laufwerk die Ansicht im Explorer in den Optionen "Ansicht" auf "Immer Symbole statt....anzeigen". Danach kannst Du die Option wieder zurückdrehen.
Ordneroptionen.png

Vielleicht hilfts...
Gruss Mario
 
Oben