Mein Laptop blockiert Webcam und Mikrofon

Dieser Thread ist Teil einer Diskussion zu einem Artikel:  Zum News-Artikel gehen

dimerZH

Mitglied
Ich kann leider bei meinem HP Laptop die Kamera und das Mikrofon nicht benutzen, kann in den Sicherheitseinstellungen die beiden Geräte nicht freigeben die Schaltflächen sind nicht aktiv. Zudem erscheint oben eine Meldung "Einige dieser Einstellungen sind ausgeblendet oder werden von Ihrer Organisation Verwaltet".
Wer kann mir helfen?
 

Anhänge

dimerZH

Mitglied
Danke für die Antwort. Das ist aber leider nicht das Problem, ich bin als Administrator angemeldet. Im Gastmodus ist die Anzeige genau gleich.
 

hirsch1

Stammgast
Vielleicht liegt es an zu restriktiven Sicherheitseinstellungen im Browser, den du ja wahrscheinlich benützt.
 

hirsch1

Stammgast
Wie sieht es im Gerätemanager aus? Hat es da bei Kamera und Mikrofon Warnungen? Manchmal hilft es, den Treiber zu deaktivieren und wieder zu aktivieren.
Man könnte auch beim Taskmanager beim Reiter DIENSTE schauen, ob die Dienste aktiviert sind. Da ich weder Kamera noch Mikro an meinem PC habe, kann ich das nicht ausprobieren.
 

Billmar

Stammgast
Hallo dimerZH

Ich vermute, dass Deine Maschine via Gruppenrichtlinien (von einer Firma) verwaltet wird.
Am einfachsten lässt sich das via Eingabeaufforderung mit Administratorberechtigung gestartet, mittels folgendem Befehl auslesen:
Code:
GPRESULT /H GPReport.html
Damit werden alle Einschränkungen von gesetzten Gruppenrichtlinien in die Datei GPReport.html geschrieben. Wenn Du diese Datei danach öffnest findest Du unter den Computerrichtlinien die Richtlinie "Windows-App-Zugriff auf die Kamera zulassen" mit dem Setting "Verweigern erzwingen".
2020-04-16 18_40_19-Window.png

Wenn Du die Berechtigung hast, die Gruppenrichtlinien zu ändern, kannst Du dies via Gruppenrichtlinieneditor bewerkstelligen. Suche dazu in der Search-Bar nach "Gruppenrichtlinie bearbeiten", oder via Eingabeaufforderung mit Administratorberechtigung mit:
Code:
gpedit
Alle in diesem Zusammenhang relevanten Einstellungen finden sich unter Computerkonfiguration => Richtlinien => Administrative Vorlagen => Windows-Komponenten => App-Datenschutz. Sie betreffen unter anderem den Zugriff auf Kamera, Mikrofon, Position, Bewegungsdaten, Kontakte oder E-Mails.
An dieser Stelle kannst Du die fragliche Einstellung für Kamera, Mikrofon etc. ändern.

Allerdings werden die Einstellungen nach einer Verbindung mit dem Firmennetzwerk wieder zurückgesetzt.
Falls Du den Richtlinieneditor nicht starten oder keine Änderungen vornehmen kannst musst Du dich an den Support Deiner Firma wenden.

Gruss
Mario
 

dimerZH

Mitglied
Im Gerätemanager sind die Kamera und das Mikrofon als funktionstüchtig erkannt es hat keine Fehlermeldungen, Treiber habe ich auch neu installiert sind auf dem neusten Stand.
 

dimerZH

Mitglied
Wenn ich den Befehl mit /R eingebe kommt folgender Report

RSOP-Daten für LAPTOP-G88JSVK1\Dieter auf LAPTOP-G88JSVK1: Protokollmodus
--------------------------------------------------------------------------
Betriebssystemkonfiguration: Eigenständige Arbeitsstation
Betriebssystemversion: 10.0.18363
Standortname: Nicht zutreffend
Roamingprofil:Nicht zutreffend
Lokales Profil: C:\Users\Dieter
Langsame Verbindung? Nein

BENUTZEREINSTELLUNGEN
----------------------
Letzte Gruppenrichtlinienanwendung: 17.04.2020, um 20:10:48
Gruppenrichtlinieanwendung von: Nicht zutreffend
Schwellenwert für langsame Verbindung:500 kbps
Domänenname: LAPTOP-G88JSVK1
Domänentyp: <Lokaler Computer>
Angewendete Gruppenrichtlinienobjekte
--------------------------------------
Nicht zutreffend
Folgende herausgefilterte Gruppenrichtlinien werden nicht angewendet.
----------------------------------------------------------------------
Richtlinien der lokalen Gruppe
Filterung: Nicht angewendet (Leer)
Der Benutzer ist Mitglied der folgenden Sicherheitsgruppen
----------------------------------------------------------
Kein
Jeder
Lokales Konto und Mitglied der Gruppe "Administratoren"
Administratoren
Benutzer
INTERAKTIV
KONSOLENANMELDUNG
Authentifizierte Benutzer
Diese Organisation
Lokales Konto
LOKAL
NTLM-Authentifizierung
Hohe Verbindlichkeitsstufe
 

Billmar

Stammgast
Sollte problemlos funktionieren. Siehe Syntax mit "GPRESULT /?"
"GPRESULT /R" zeigt leider nur die RSoP-Zusammenfassungsdaten an und nicht die gesetzten Werte.

GPRESULT /?
. . . .
. . . .
. . . .
. . . .
/R Zeigt RSoP-Zusammenfassungsdaten an.

/V Legt fest, dass ausführliche Informationen
angezeigt werden sollen. Dadurch werden
zusätzliche detaillierte Einstellungen, die
mit 1 angewendet wurden.

/Z Legt fest, dass besonders ausführliche
Informationen angezeigt werden sollen. Diese
Informationen zeigen zusätzliche
detaillierte Einstellungen, die mit 1 oder
höher angegeben wurden, an. Somit können Sie
erkennen, ob eine Einstellung an mehreren
Stellen gesetzt wurde. Weitere Informationen
erhalten Sie in den Gruppenrichtlinien-
Onlinehilfethemen.

/? Zeigt diese Hilfe an.


Beispiele:
GPRESULT /R
GPRESULT /H GPReport.html
GPRESULT /USER Zielbenutzername /V
GPRESULT /S System /USER Zielbenutzername /SCOPE COMPUTER /Z
GPRESULT /S System /U Benutzername /P Kennwort /SCOPE USER /V

GPRESULT /H NameDerAusgabedatei.html und danach die NameDerAusgabedatei.html öffnen sollte die gesetzten Policies im Browser anzeigen.

Gruss
Mario
 

dimerZH

Mitglied
Danke Mario für deine Geduld, vielleicht mache ich etwas falsch?
Bei mir geht der Befehl leider so nicht. Siehe folgende Anzeige:

PS C:\WINDOWS\system32> GPRESULT /H GPReport.html
FEHLER: Ungültige(s) Option/Argument - "/H".
Geben Sie "GPRESULT /?" ein, um die Syntax anzuzeigen.
PS C:\WINDOWS\system32>

Gruss Dieter
 

malamba

Stammgast
Konntest du früher mal die Cam und Mikrofon benutzen. Wenn ja, ab wann funktionierten diese nicht mehr. Mögliche Veränderungen an....vorgenommen, Programme installiert oder deistalliert?
 

Billmar

Stammgast
Hallo Dieter

Jetzt sehe ich das Problem :)
Du führst die Befehle in PowerShell aus. In der PowerShell-Umgebung reagieren die "Command-Line-Tools" nicht wie in einer "Eingabeaufforderung (CMD)". Ich war da bei meiner Beschreibung etwas zu ungenau.
Öffne die "Eingabeaufforderung" mit Administratoren-Rechten indem Du in der Search-Bar "cmd" oder "Eingabeaufforderung" eingibst und dann "Als Administrator ausführen" anwählst.

2020-04-18 08_45_57-Window.png

In dieser Umgebung kannst Du jetzt die beiden Befehle für die Richtlinienanzeige absetzen:
Code:
gpresult /H Gpresult.html
Gpresult.html
Damit solltest Du die gesetzten Gruppenrichtlinien aus der Datei GPReport.html im Browser angezeigt bekommen.
Weiter geht es dann mit dem Entfernen der Richtlinie mit "gpedit" wie in meinem ersten Beitrag beschrieben.

Gruss
Mario
 

dimerZH

Mitglied
Hallo Mario
genauso habe ich es doch schon vorher gemacht??? was ist falsch ich versteh das nicht das Argument /H geht bei meinem Betriebssystem nicht.

1587195693721.png

Danke für deine Hilfe
Gruss Dieter
 

dimerZH

Mitglied
Ich bin auch gar nicht mit einem Firmennetzwerk verbunden, das Problem ist sicher schon länger so wenn nicht immer, ich habe die Kamera wohl noch nie benutzt auf diesem Laptop.
Der Befehl gpedit ist auch unbekannt in der Eingabeaufforderung
1587196620110.png
 

hirsch1

Stammgast
Ich habe hier einen Link gefunden, um die Webcam zu testen.
 

Billmar

Stammgast
OK, nächstes Problem :)
Du verwendest offenbar eine Windows Home Version die ist leider etwas eingeschränkt :-( ich kenne die Details der Einschränkungen leider nicht und habe keine Home-Version verfügbar.

Deine Windows-Version kannst Du mit "Windows + R" Taste und der Eingabe "winver" feststellen.

In diesem Falle könnte man das Problem ev. versuchen via Registry zu lösen. Ich hoffe, dass wenigstens der Registry-Editor funktioniert ;-) und die Berechtigungen auf den Policy-Zweig nicht eingeschränkt sind.

In der Registry geht es um den Zweig [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppPrivacy] welcher geändert bzw. gelöscht werden sollte.

  1. Wähle den Registry-Editor mit Eingabe von "regedit" in der Search-Bar und führe es als Administrator aus
  2. Gehe zum Eintrag Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppPrivacy links in der Strukturansicht
  3. Falls dort im rechten Teil des Fensters Werte wie z.B. "LetAppsAccessCamera" setze diese auf den Wert 0 oder lösche den Wert

Das Ganze kann auch in einer "Eingabeaufforderung" mit Admin-Rechten gemacht werden.
Die erste Zeile sichert die fraglichen Registry-Schlüssel in eine "Backup-Datei" auf dem Desktop.
Die zweite Zeile löscht den fraglichen Registry-Schlüssel aus der Registry.

Code:
reg export HKLM\SOFTWARE\Policies\Microsoft\Windows\AppPrivacy "%userprofile%\Desktop\regback.reg"
reg delete HKLM\SOFTWARE\Policies\Microsoft\Windows\AppPrivacy /f
Noch eine Frage:
Welche Antiviren Software verwendest Du? Bei vielen dieser Apps kann man den Zugriff auf die Kamera einschränken - vielleicht liegt da das effektive Problem?

Viel Erfolg und Gruss
Mario
 
Zuletzt bearbeitet:

dimerZH

Mitglied
Hallo Mario
Ja ich habe nur eine Home-Version
1587222957280.png
Deinen Vorschlag werde ich versuchen auszuführen. Regedit funktioniert das habe ich auch schon verwendet.

Danke für deine Hilfe, ich hoffe es klappt bald, ich melde mich.

Gruss Dieter
 
Oben